Photo upload issue

This forum is for all other types of chatter, including non-SCUBA stuff.
Post Reply
User avatar
dlh
Extreme Diving Machine
Posts: 487
Joined: Mon Jan 07, 2008 8:10 pm

Photo upload issue

Post by dlh » Fri Dec 20, 2019 9:58 am

I ran into a problem where a couple of photos are not accepted by the attachment upload feature. I get a warning that the image dimensions can't be determined. These are photos exported by Lightroom at 2000 pixels, but only two of the same batch can't be read. I tried a few different things like exporting to 1000 or 2400 pixel, saving with Photoshop, and another non-adobe utility. This particular image refused to upload.

I attached it to this post, can inline the picture. Onedrive link: https://1drv.ms/u/s!Alr8qi46H3EcgP-ZQCk ... o?e=kUeJ2R
Dave

User avatar
YellowEye
I've Got Gills
Posts: 2575
Joined: Sun Oct 29, 2006 8:08 am

Re: Photo upload issue

Post by YellowEye » Fri Dec 20, 2019 11:46 am

Wow, only 818k.
I've had issues too. But usually if i limit the file size to 1500k by reducing max file size it resolves it.
Last edited by YellowEye on Fri Dec 20, 2019 4:28 pm, edited 1 time in total.

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 1:22 pm

Ugh, these upload errors are a nuisance. I’ll take a look when I get a chance. Thanks for the problematic file, and sorry about the hassle.

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 4:04 pm

Guys, can you help test something? I can confirm that saving every which way, and size doesn’t change the error. However “save for web” does allow this image to be uploaded.

So far the only difference may be that a bunch of edit history metadata is stripped out when saved for web. Can you guys each try to save any problematic files in “save for web” format and/or strip out all but copyright and ownership metadata?

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 4:08 pm

Also, it looks like File > Save As causes some problems whereas File > Export in Photoshop allows it to be posted, even with all the metadata.

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 4:11 pm

Export in Lightroom seems to fix it as well too. Please give a try and let us know.

User avatar
YellowEye
I've Got Gills
Posts: 2575
Joined: Sun Oct 29, 2006 8:08 am

Re: Photo upload issue

Post by YellowEye » Fri Dec 20, 2019 4:20 pm

I use lightroom export, and had problems there, but turning off meta data helped on one image I tried!

Surprisingly removing metadata brought the filesize down from 2mb to 1.6mb!

Here's what I changed in lightroom
dialog.png
Thanks Calvin! Will keep trying that!
Last edited by YellowEye on Fri Dec 20, 2019 4:22 pm, edited 2 times in total.

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 4:21 pm

There are no dimension size limits anymore btw, so it shouldn’t be that.

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Fri Dec 20, 2019 4:23 pm

Yep, YellowEye! The metadata is at the heart of these problems, I think.

I minimize it out of habit anyway.

User avatar
YellowEye
I've Got Gills
Posts: 2575
Joined: Sun Oct 29, 2006 8:08 am

Re: Photo upload issue

Post by YellowEye » Fri Dec 20, 2019 4:23 pm

Previously I was using the "limit file size" option to get things to work. Perhaps that strips out metadata behind the scenes in some cases!
Thank you!

User avatar
dlh
Extreme Diving Machine
Posts: 487
Joined: Mon Jan 07, 2008 8:10 pm

Re: Photo upload issue

Post by dlh » Sat Dec 21, 2019 9:59 am

Yes, metadata it is. I changed the LightRoom Export metadata setting to:

LR Export.png
LR Export.png (8.2 KiB) Viewed 432 times

Here is the problematic photo with just the metadata adjustment:
Redondo Pier December 12, 2019 (70 of 212).jpg
Dave

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Sat Dec 21, 2019 10:12 am

What a stunning photo!! Well worth figuring out the metadata issue.

Eric, I wonder if this is the root cause of Jess’ photo posting troubles. Can you help check her native phone camera app to see if there’s a way to limit metadata? I bet that’s why it only uploads if she does some edit- it’s probably re-saving it without some problematic metadata.

User avatar
Gdog
NWDC Moderator
NWDC Moderator
Posts: 3706
Joined: Mon Mar 31, 2008 7:41 pm

Re: Photo upload issue

Post by Gdog » Sat Dec 21, 2019 11:30 am

That would be odd tho, becaus if that was the issue with Android OS, then my phone would suffer the same issue you would think.

User avatar
dlh
Extreme Diving Machine
Posts: 487
Joined: Mon Jan 07, 2008 8:10 pm

Re: Photo upload issue

Post by dlh » Sat Dec 21, 2019 11:47 am

My guess is that the board software has some sort of string-parsing defect that is causing it to choke and do wrong things when ingesting metadata. I've never actually hit this problem before the last week or so. Could be that some change to the board software introduced the bug OR some change to Lightroom introduced some new tag, string, or other formatting quirk that is tripping thing up in new ways.

Probably most pictures work most of the time, but some magic string is breaking it.
Dave

Tangfish
NWDC Mascot
NWDC Mascot
Posts: 7524
Joined: Fri Dec 30, 2005 2:11 pm

Re: Photo upload issue

Post by Tangfish » Sat Dec 21, 2019 12:38 pm

Gdog wrote:That would be odd tho, becaus if that was the issue with Android OS, then my phone would suffer the same issue you would think.
There are so many different variations of android phones and operating systems, not to mention settings. Could be one of those factors.

Post Reply